Ribbon

<< Click to Display Table of Contents >>

Navigation:  Getting Started > User Interface explained >

Ribbon

Overview

The Ribbon contains the main controls to manage each Process Model. These are organized into different tabs, and are described below.

 

Home tab

The following is the Home tab displayed when a user first opens Modeler, and when working on local-stored models.

 

The Ribbon1v24

 

 

MENU OPTION

SUB OPTION

DESCRIPTION

 Clipboard

Paste

Insert the current contents of the clipboard into the diagram.

Cut

Remove the selection from the diagram and put it on the clipboard.

Copy

Copy the selection from the diagram and put it on the clipboard.

 Model

Diagrams

Open the diagram browser.

Run Workflow

Turn your Process into a running applications. Visit www.bizagi.com

Simulation View

Bizagi Modeler allows simulation your business processes under the BPSim (Business Process Simulation) to support decision making and boost theit continuous improvement.

Resources

Add, edit or remove resources. These are the roles, systems or people that execute activities.

Validate

Check for modeling errors on the active diagram.

Info

Show the diagram information.

 Bizagi Cloud

Save as

Allows to save the Model in Cloud or locally.

Learn more about storing in Bizagi Cloud.

Share

Allows to share your model using the Bizagi Cloud services. When the user is NOT logged in to Cloud or working on a model not owned by him/her, this option will display a pop-up windows allowing the user to Start a free trial or learn more about Cloud Collaboration Services.

 Formatting

 

Font

Change the font face.

Font Size

Change the font size.

Grow Font

Increase the font size.

Shrink Font

Decrease the font size.

Bold

Make the selected text bold.

Italic

Italicize the selected text.

Underline

Underline the selected text.

Strikethrough

Draw a line through the middle of the selected text.

Font Color

Change the color of the text.

Shading

Color the background behind the selected text.

Text alignment

Change the color of the text.

Clear Formatting

Remove custom formatting, leaving only the plain text.

Editing

 

Find

Find text in the model.

Select

Select elements in the diagram.

Delete

Clear formatting from selected elements or delete selected elements

Review

Spelling

Open the spell-check feature to proof text entered in the process and documentation.

View more information about the Spelling review option.

 Discover

Bizagi Suite

Learn more about Bizagi’s BPM Suite

Online Courses

Provide access to E-Learning sites.

 

Home tab changes slightly when a user works on Model stored in Bizagi Cloud.

A new menu and a new set of options under Bizagi Cloud menu are displayed. Options will be enabled or disabled depending on whether the user is the owner of the model or not.

 

The Ribbon1v3

 

MENU OPTION

SUB OPTION

DESCRIPTION

 Bizagi Cloud

Share

Allows to share your model using the Bizagi Cloud services. This option is available when the user is the owner of the current model.

Properties

Opens the Cloud model properties

Work Offline

Opens a window to chose diagrams of the current model to be available to work offline.

Work Online

Enables an offline model to be back online, after being offline, to synchronize all changes.

bizagi.com

Opens a new browser taking the user to Bizagi.com and display all models stored in Bizagi Cloud.

Diagram

Check Out

Locks the diagram in other to avoid other Editors to perform changes. This option is available when the diagram is Read Only.

Check In

Releases the diagram in other to let other Editors to perform changes. This option is available when the diagram is being editing by you.

Comments

Opens the Comments panel in order to let the users to make comments, This option is not available when the user is the owner of the current model and has a Personal Plan.

 

Format tab

 

The Ribbon2v24

 

MENU OPTION

SUB OPTION

SUB OPTION

Layout

Align

Align selected elements. It is possible to align them to the top, bottom, left and right of the diagram.

Align Horizontal

Align the selected items horizontally.

Align Vertical

Align the selected items vertically.

Distribute horizontally

Distributes selected elements with even horizontal spaces between them.

Distribute vertically

Distributes selected elements with even vertical spaces between them.

Formatting

Font

Change the font face.

Font Size

Change the font size.

Grow Font

Increase the font size.

Shrink Font

Decrease the font size.

Bold

Make the selected text bold.

Italic

Italicize the selected text.

Underline

Underline the selected text.

Strikethrough

Draw a line through the middle of the selected text.

Font Color

Change the color of the text.

Shading

Color the background behind the selected text.

Text alignment

Align text: center, left and right.

Clear Formatting

Remove custom formatting, leaving only the plain text.

 

View Tab

 

The Ribbon3v24

 

 

MENU OPTION

SUB OPTION

DESCRIPTION

View

Lock

Locks/ unlocks the diagram for editing (read-only).

Zoom

Zoom In

Enlarge the view of the model.

Zoom Out

Reduce the view of the model.

Scale

Apply a preset zoom level for quick enlargement or reduction of the diagram (100% default).

100%

Apply a 100% zoom to the normal diagram size.

Fit to Diagram

Scale the page so that the entire diagram fills the viewing area.

Zoom to selection

Scale the page so that only the selected elements of the diagram fill the viewing area.

Pan

Display a view of the page at a smaller magnification in order to browse through the diagram.

Show

Grid

Display grid lines for visual reference to aid alignment of a diagram's elements.

Black and white

Change the color mode of the diagram to black and white.

Presentation actions

Highlight the diagram elements that contain actions in presentation mode.

Gradient fill

 

Fill elements with a background color that gradually changes from one color to another across the surface of the element.

Shadows

Attach a drop shadow to the element. Shadows are attached to the bottom-right corner of the element.

Spelling mistakes

Highlight the spelling mistakes found in text.

Alignment

Align to grid

Automatically aligns an element to the nearest intersection of lines in the grid.

Smart align

Automatically aligns diagram elements to the grid in relation to one another.

 

Publish Tab

The Ribbon14

 

MENU OPTION

SUB OPTION

DESCRIPTION

Process documentation

Word

Generate a Word file of the model and all its documentation.

PDF

Generate a PDF file of the model and all its documentation.

Excel

Generate an Excel file of the model and all its documentation.

Web

Generate a Web file of the model and all its documentation for web browsing.

SharePoint

Export and publishes the model to SharePoint.

Wiki

Export and publishes the model to Wiki.

 

Export / Import Tab

 

The Ribbon4

 

MENU OPTION

SUB OPTION

DESCRIPTION

Export

Image

Export the active diagrams as an image.

Visio

Export the model as a Visio file.

XPDL

Export the model as a XPDL file.

Attributes

Save the extended attributes as a XML file.

BPMN

Export the model as a BPMN file.

Import

Visio

Create a new diagram based on a Visio file.

XPDL

Create a new diagram based on a XPDL file.

Attributes

Import extended attributes from a XML file.

BPMN

Create a new diagram based on a BPMN file.

 

Tools tab

 

The Ribbon5

 

MENU OPTION

SUB OPTION

DESCRIPTION

 

Tools

Cloud Attachments

Shows a list of all attachments uploaded to the opened Cloud model. This option is only available when a Cloud model is opened.

Attachments

Shows all the attachments in the model: the element to which the attachment relates and the corresponding file name.

Element Count

Shows the count of diagram elements by type. The table displays a list of Processes by name, and the number of Events, Gateways, Sub-processes and Tasks.

Custom artifacts

Shows the Custom Artifacts Types Manager to create, edit, delete, export and import custom artifacts.

Team collaboration

Categories

Lists all the categories available in the local Team collaboration to be managed.

Delete comments

Enables the possibility to delete all comments in the local Team collaboration.

 

Help tab

 

The Ribbon6

 

MENU OPTION

SUB OPTION

DESCRIPTION

Help

Help

Displays this User Guide.

Video tutorials

Guides you to Bizagi's video tutorials.

Support forums

Access to the online support forums.

Process XChange

Access to the Bizagi’s Process XChange process templates and discussion forums.

Community

Register

Bizagi Modeler community registration.

Tell a Friend

A link that enables you to share Bizagi Modeler with clients, colleagues and friends.

 

About

Take a tour

Takes you to a short tour through the main features of Bizagi.

Release notes

Information on the current release.

About

Information about Bizagi Modeler.

 

File - New

 

The Ribbon9

 

MENU OPTION

SUB OPTION

DESCRIPTION

New

Blank Model

Creates a new blank model.

 

File - Open

 

The Ribbon7

 

MENU OPTION

SUB OPTION

DESCRIPTION

Open

Recent Models

Lists all Models, stored locally or in Bizagi Cloud, to be opened.

Bizagi Cloud

Enables the option to open an existing Bizagi Cloud Model.

Local Models

Enables the option to open an existing Local Model.

 

File - Print

 

The Ribbon10

 

MENU OPTION

SUB OPTION

DESCRIPTION

Print

Print

Selects a printer, number of copies and other printing options in order to print your diagram.

Quick Print

Immediately prints the active diagram to the default printer.

Print Preview

Onscreen preview of the diagram in print layout mode, allowing layout modifications prior to printing.

 

File - Save & Publish

 

The Ribbon11

 

MENU OPTION

SUB OPTION

DESCRIPTION

Send Using E-Mail

Send as Attachment

Send a copy of the model as an attachment in an e-mail message

Send as Image

Send the model as images in an e-mail message.

Send as XPDL

Send the model as an XPDL file in an e-mail message.

Publish Documentation

Word

Generate a Word file of the model and all its documentation.

PDF

Generate a PDF file of the model and all its documentation.

Web

Generate a Web file of the model and all its documentation for web browsing.

SharePoint

Export and publish the model to SharePoint.

Wiki

Export and publish the model to Wiki.

Export to Others Formats

Image

Export the active diagrams as an image.

Visio

Export the model as a Visio file.

XPDL

Export the model as an XPDL file.

Attributes

Save the extended attributes as an XML file.

Other Versions (Model v 1.6)

Export the model to the 1.6 version of Bizagi Modeler (.bpm).

 

File - Options

 

The Ribbon13

 

MENU OPTION

SUB OPTION

DESCRIPTION

User Interface Options

Mode

Hide or show elements on the drawing palette. Core will enable only the most common BPMN elements. Extended will enable all BPMN elements.

Language

Change the Bizagi Modeler language.

Enable right to left writing

Enables all text fields to input text from right to left. Specially useful for RTL languages.

BPMN element options

Font

Define the default font for all diagram elements.

Configure default sizes

Launch the wizard that sets the element's default sizes

Custom Artifacts

Custom Artifacts

Opens the Custom artifacts management window

Alerts

Warn element type changes

Displays a warning message when an element changes type. Unintentional change of type may result in data loss.

Warn when too many tabs are opened

Displays a warning message when the model (the .bpm file) has more than 10 diagrams (tabs) opened. When there are more than 10 diagrams opened the performance of the Modeler might get affected.

 

 

The Ribbon12

 

MENU OPTION

SUB OPTION

DESCRIPTION

General Settings

Logo

Allow customization of a user-defined logo, once the model's documentation is ready for generation.

Extended attributes

Import

Import the extended attributes from XML file.

Export

Export the extended attributes from XML file.

Word Templates

Word Templates

Select a Word template (.dot file) to generate Word documentation.