System requirements

<< Click to Display Table of Contents >>

Navigation:  Welcome to the Bizagi Modeler 3.7 and Modeler Services documentation > Getting started >

System requirements

Overview

To install Bizagi Modeler, consider that your PC or laptop needs to comply with the following requirements.

 

Requirements

The system requirements encompass:

Minimum hardware requirements, which will enable Bizagi Modeler to run with better performance.

Supported operating systems.

Software as a prerequisite, supporting the technology used by Bizagi Modeler.

Additional software, which is only needed to publish documentation, or to view such published documentation.

 

1. Hardware

System architecture: 64-bit (x64).

Processor: 2 gigahertz (GHz) or above. 2 cores or superior.

Memory: 4 GB RAM minimum, 8 GB RAM recommended (or higher).

Hard drive: 1 GB minimum disk space available.

Display: 1920 x 1080 or higher resolution.

 

2. Operating systems

Windows 10

Windows 8.1

Windows 7

Windows Server 2016.

Windows Server 2012 R2.

 

 

3. Software prerequisites

Microsoft's .NET framework 4.6.1.

Internet Explorer 11.

You may download Microsoft's .NET framework 4.6.1 from Microsoft's official website at https://www.microsoft.com/en-us/download/details.aspx?id=49982.

 

4. Additional software

Such software is required in those PCs or laptops, where documentation needs to be published or viewed.

 

REQUIRED SOFTWARE

SUPPORTED VERSIONS

WHEN IS IT NEEDED?

Microsoft Word

2016, 2013, 2010

When publishing to Word.

Microsoft Excel

2016, 2013, 2010

When publishing to Excel.

Microsoft Visio

2016, 2013, 2010

When importing or exporting to Visio.

Microsoft Office SharePoint Server

2016, 2013, 2010, SharePoint Online

When publishing to SharePoint.

Browsers

Either:

Microsoft Edge

Internet Explorer 11

Chrome 24 or higher

Mozilla Firefox 19 or higher

Only to view published documentation in web format (includes that one published in SharePoint).

MediaWiki

1.14 to 1.22.

Consider that MediaWiki by itself may have its own requisites (i.e., PHP).

Only when publishing to MediaWiki.

Oracle Java (JRE)

JRE 6 (installed portably by Bizagi Modeler)

Only when using Simulation.

 

5. Enable trusted sites (URL Requirements) and Proxy

Add these exceptions to your corporate proxy and firewall, in the same way, add the following URLs to your browser's trusted sites:

 

Domain

Required

Purpose

Proxy/firewall

Browser

*.bizagi.com

ü

ü

User Registration

*.azurewebsites.net

ü

ü

Accounts authentication

*.azureedge.net

ü

ü

Load websites with CDN (Content Delivery Net)

*.windows.net

ü

ü

Cloud file management / Modeler download

*.msecnd.net

ü

Optional

Desktop application Telemetry (handle application information like requests, errors, etc)

*.google.com

ü

û

Log in with Google accounts

*.microsoftonline.com

ü

û

Log in with Microsoft accounts

*.googleapis.com

û

Optional

Manage Google fonts for the best user experience

*.googletagmanager.com

Optional

Optional

Desktop application telemetry aimed at improving usability

*.google-analytics.com

Optional

Optional

Desktop application telemetry aimed at improving usability

*.d41.co

Optional

Optional

Suggest the company's name, in Bizagi users registration

Enable port 443.

 

 

For Modeler Services, please click the following link.